Dashboard

It's a little bit of scope creep for this story, but this snippet appears in a million places. Let's try and consolidate it somehow in our tests.

It's a little bit of scope creep for this story, but this snippet appears in a million places. Let's try and consolidate it somehow in our tests.

This guy belongs in languageJvm.

This guy belongs in languageJvm.

Could use a better name. I wasn't sure what this was really testing on first glance.

Could use a better name. I wasn't sure what this was really testing on first glance.

This is not quite accurate enough. Should use System.identityHashCode().

This is not quite accurate enough. Should use System.identityHashCode().

Is there a reason to not make this session scoped?

Is there a reason to not make this session scoped?

This isn't the point. The point is faster compilation. Need to change the title. We should add more specifics about what kinds of compilation this affects. It's probably also worth mentioning that...

This isn't the point. The point is faster compilation. Need to change the title.

We should add more specifics about what kinds of compilation this affects. It's probably also worth mentioning that it doesn't help Java compilation unless people have changed it from the default of running in the build process.

These tests are too fragile. Need to find a better way.

These tests are too fragile. Need to find a better way.

I don't think we should add such a switch until we are sure there are problems that can't be fixed at the cause.

I don't think we should add such a switch until we are sure there are problems that can't be fixed at the cause.

Out of scope.

Out of scope.

Remove logging full stacktrace on recoverable daemon connection attempts

+review REVIEW-5610

Reworked how deprecation messages are triggered for the standard lifecycle tasks and switched test on again. This is really a workaround for some issues in model reuse, that will get sorted out later.

Minor tweaks to reduce time in locked sections

+review REVIEW-5606

add documentation for Yourkit integration

+review REVIEW-5607

Remove workaround for GRADLE-2316

+review REVIEW-5610

support default yourkit behaviour for experiment performance test

+review REVIEW-5607

GRADLE-2316 Detect TCP self-connect and retry connection

When attempting to connect to the daemon, if the daemon has not bound

to the port, there is a small chance that the OS may attempt to bind and

connect to the same port. When this happens, data written to this socket

is "reflected" back on the receiving side.

This change attempts to detect that by comparing the local and remote

addresses. If they are the same, we assume that we have self-connected

and need to retry the connection. Since ports are assigned sequentially

most of the time, this should work on the second retry.

+review REVIEW-5610

Remove notes for GRADLE-2316

Trigger the master build pipeline

GRADLE-2316 Detect TCP self-connect and retry connection
GRADLE-2316 Detect TCP self-connect and retry connection
GRADLE-2316 Add more debug logs and diagnostic information to DaemonClient failures

+review REVIEW-5610

Integration tests for lists of scalar types in managed types. * Adds an integration to check mutation of lists * Prepares for read/write properties

+review REVIEW-5608

Add contributor to release notes

    • -1
    • +2
    /subprojects/docs/src/docs/release/notes.md
Merge pull request #514 from jw3/dist-doc-fix

typo; main and dist were transposed

Add theories of failure

    • -0
    • +73
    /design-docs/GRADLE-2316.md
Initial support for Lists of scalar types in managed properties

+review REVIEW-5608

Initial support for Lists of scalar types in managed properties

+review REVIEW-5608

Adds the ability to create buildTypes for project buckets
Adds the ability to create buildTypes for project buckets
Fixes package exclude pattern

Adds the ability to create buildTypes for project buckets

+review

    • -0
    • +60
    /gradle/buildSplits.gradle
Add more logging to ease debugging

+review REVIEW-5606